On 12 Feb 2003 at 05:45, Frank Heckenbach wrote:
But it should be possible with moderate effort to implement something like
export Foo = all (FileMode => GPC_FileMode);
so one won't have to name all interface declarations, but only the re-exports and renamings explicitly.
Ok. I'd rather not touch any EP stuff (e.g., modules) at all. However, if that is going to be the only realistic option, then I guess it would have to do ...
Even when QI will work sometime, I think export renaming is still the better solution (shorter to write, and a little more efficient), so you might as well get used to it. :-)
As I said, the problem currently is that the syntax given above doesn't work yet, but you'd have to name all regular exports in the `export' clause as well.
Any opinions (also from others interested) on whether I should add this feature, and if so, with the syntax above or differently?
I can't see many responses to this, so perhaps I am the only one who needs it. The syntax that you suggest above is quite fine by me.
Best regards, The Chief -------- Prof. Abimbola A. Olowofoyeku (The African Chief) web: http://www.bigfoot.com/~african_chief/
Prof A Olowofoyeku (The African Chief) wrote:
On 12 Feb 2003 at 05:45, Frank Heckenbach wrote:
But it should be possible with moderate effort to implement something like
export Foo = all (FileMode => GPC_FileMode);
so one won't have to name all interface declarations, but only the re-exports and renamings explicitly.
Ok. I'd rather not touch any EP stuff (e.g., modules) at all. However, if that is going to be the only realistic option, then I guess it would have to do ...
Even when QI will work sometime, I think export renaming is still the better solution (shorter to write, and a little more efficient), so you might as well get used to it. :-)
As I said, the problem currently is that the syntax given above doesn't work yet, but you'd have to name all regular exports in the `export' clause as well.
Any opinions (also from others interested) on whether I should add this feature, and if so, with the syntax above or differently?
I can't see many responses to this, so perhaps I am the only one who needs it. The syntax that you suggest above is quite fine by me.
I can imagine using it myself if I turn `System' into a module to resolve the `Integer = Integer (16)' issue, as suggested by Emil.
So I'll try to implement it like this.
Frank