Contestcen@aol.com wrote:
<< BTW, native speakers, with formulation is better, "integer with/of N bits"? >>
The description "Integer of N bits" is better. For the declaration, both IntegerOfBits(n) and IntegerWithBits(n) seem awkward. I would prefer the shorter IntegerOf (n) or possibly IntegerOfSize (n).
I feel we should use consistent terminology. The SizeOf function returns a number of bytes, the BitSizeOf function returns a number of bits. Using just "size" when the requested parameter is a number of bits, introduces sloppy terminology, which - in general - is a source of programming errors. With IntegerOf(n), one can (implicitely) read IntegerOf(bits), so I think that is OK.
Regards,
Adriaan van Os